CYBERSECURITYTRACKER
Permanent story citation

NCSC-2026-0427 Vulnerabilities Fixed in Ahsay AhsayCBS

This page keeps the story as Cybersecurity Tracker first published it. If the tracker later corrects it, the correction appears below the original and never replaces it.

Back to newsStory 10263

As cited

Copy frozen at (site build).

vulnerabilities

NCSC-2026-0427 Vulnerabilities Fixed in Ahsay AhsayCBS

Ahsay released security updates for AhsayCBS through version 10.3.2 to address two critical vulnerabilities. CVE-2026-105133 (CVSS 7.3) involves insufficient authentication in the checkSysPwd function of the AhsayCBS application programming interface (API), allowing unauthenticated remote attackers to bypass authentication. CVE-2026-105134 (CVSS 10.0) is an OS command injection flaw in the Replication Receiver accessible via /rps/api/json/UpdateReceivers.do that enables remote code execution, and researchers have observed active exploitation combining both vulnerabilities in a single attack chain.

Why it matters: Organizations running AhsayCBS must update immediately to version 10.3.2 to block remote code execution; the NCSC advises investigating potentially compromised systems for indicators including suspicious directories, unauthorized RPS receivers, and unauthorized administrative accounts.

Source published
First seen by Cybersecurity Tracker

Source attribution

Correction

Correction recorded as of .

vulnerabilities

NCSC-2026-0427 Vulnerabilities Fixed in Ahsay AhsayCBS

Ahsay released security updates for AhsayCBS through version 10.3.2 to address two critical vulnerabilities. CVE-2026-105133 (CVSS 7.3) involves insufficient authentication in the checkSysPwd function of the AhsayCBS application programming interface (API), allowing unauthenticated remote attackers to bypass authentication. CVE-2026-105134 (CVSS 10.0) is an OS command injection flaw in the Replication Receiver accessible via /rps/api/json/UpdateReceivers.do that enables remote code execution, and researchers have observed active exploitation combining both vulnerabilities in a single attack chain.

Why it matters: Organizations running AhsayCBS must update immediately to version 10.3.2 to block remote code execution; the NCSC advises investigating potentially compromised systems for indicators including suspicious directories, unauthorized RPS receivers, and unauthorized administrative accounts.

Source published
First seen by Cybersecurity Tracker

Source attribution

Glossary