CYBERSECURITYTRACKER
Permanent story citation

Critical Langflow Flaws Could Let Unauthenticated Attackers Run Code on Servers

This page keeps the story as Cybersecurity Tracker first published it. If the tracker later corrects it, the correction appears below the original and never replaces it.

Back to newsStory 12040

As cited

Copy frozen at (site build).

vulnerabilities

Critical Langflow Flaws Could Let Unauthenticated Attackers Run Code on Servers

Two critical vulnerabilities in Langflow, an open-source tool for building artificial intelligence (AI) agents and workflows, allow unauthenticated attackers to bypass authentication or execute arbitrary code on affected servers. All versions from 1.0.0 through 1.12.8 contain the flaws; patching requires upgrading to version 1.13.0. Neither vulnerability is currently tracked in CISA's Known Exploited Vulnerabilities list.

Why it matters: Organizations running Langflow 1.12.8 or earlier face immediate risk of remote code execution (RCE) by unauthenticated attackers and must upgrade to 1.13.0 to patch both critical issues.

Source published
First seen by Cybersecurity Tracker

Source attribution

Glossary