CYBERSECURITYTRACKER
Permanent story citation

CVE-2026-86287: Net::IP::LPM versions before 1.12 for Perl accept malformed prefix lengths

This page keeps the story as Cybersecurity Tracker first published it. If the tracker later corrects it, the correction appears below the original and never replaces it.

Back to newsStory 6602

As cited

Copy frozen at (site build).

vulnerabilities

CVE-2026-86287: Net::IP::LPM versions before 1.12 for Perl accept malformed prefix lengths

CVE-2026-86287 affects Net::IP::LPM, a Perl module for IP longest prefix matching, in versions before 1.12. The vulnerability allows acceptance of malformed prefix lengths, which could lead to unexpected behavior or security issues in applications that rely on this module for IP address processing.

Why it matters: Perl developers and system administrators using Net::IP::LPM for IP routing or access control logic must upgrade to version 1.12 or later to prevent potential bypass or logic errors caused by malformed input.

Source published
First seen by Cybersecurity Tracker

Source attribution

Correction

Correction recorded as of .

vulnerabilities

CVE-2026-86287: Net::IP::LPM versions before 1.12 for Perl accept malformed prefix lengths

Net::IP::LPM, a Perl module for IP address prefix matching, contains a vulnerability in versions before 1.12 that allows acceptance of malformed prefix lengths. The issue carries a CVSS 3.1 score of 7.5 and affects the module's input validation.

Why it matters: Perl developers and systems using Net::IP::LPM for IP routing or filtering logic should upgrade to version 1.12 or later to prevent potential exploitation through crafted prefix inputs.

Source published
First seen by Cybersecurity Tracker

Source attribution

Glossary